iOS 4.3.4 and iOS 4.2.9 for Verizon iPhone Released by Apple [Direct Download]

Apple_iOS_4.3.4_and_iOS_4.2.9_Direct DownloadApple has released its new iOS 4.3.4 for iPhone, iPad and iPod Touch and along with it iOS 4.2.9 for Verizon iPhone that is to fix the vulnerability allowing Comex to use in JailbreakMe 3.0 to Jailbreak iPhone, iPad and iPod Touch.

You all know about Comex’s JailbreakMe which was released earlier this week to help Jailbreak iPhone, iPad and iPod Touch using the Userland Exploit and to install Cydia on your iOS device just using mobile Safari. Keeping in mind the Userland exploit Apple last week had released patch to Fix the Userland exploit vulnerability of iOS.

According to Apple Release Note, iOS 4.3.4 and iOS 4.2.9 is having following changes,

Fixes security vulnerability associated with viewing malicious PDF files.

Apple iOS Devices supported by 4.3.4:

  • iPhone 4, iPhone 3GS
  • iPod Touch 4G, iPod Touch 3G
  • iPad 2, iPad 1

iDevices Supported by iOS 4.2.9:

  • Verizon iPhone 4

Comex expected Apple to release an iOS software update (iOS 4.3.4) to fix the vulnerability used in JailbreakMe 3.0 and has advised users to take a backup of SHSH blobs. You can useTinyUmbrella for iOS 4.3.3 or iOS 4.2.8 to take a backup of your SHSH blobs so that you can downgrade to the older version of iOS if required. Jailbreakers and iPhone unlockers should also avoid upgrading to iOS 4.3.4 if it is released, until the jailbreak community does not release the latest tools for iOS 4.3.4.

If you don’t want to upgrade to iOS 4.3.4, but don’t want to be exposed to the security vulnerability then you can install PDF Patcher 2 on Cydia to fix the vulnerability associated with viewing malicious PDF files.

Now if you are not fan of Jailbreaking or unlocking your iPhone, iPad or iPod Touch, you can simply update your devices iOS to 4.3.4 or iOS 4.2.9 via iTunes.

You can download iOS 4.3.4 and iOS 4.2.9 for your iPhone, iPad or iPod Touch here [Direct Links Here]

 

Comments

  1. George Svenson says:

    damn i really wanted an untether for 4.2.9, oh well, i guess ill just use kittyra1ns tethered for 4.2.9

  2. Dorinda Asaeli says:

    It is actually a nice and helpful piece of information. I’m happy that you shared this useful information with us. Please stay us informed like this. Thank you for sharing.

Speak Your Mind

*